Yes, you need to KYC.

Unfortunately, for legal reasons, we cannot accept users from the United States, the Cayman Islands, or South Africa.

Did this answer your question?